A brief note about ChemDraw, Microsoft Office 2016/365 and the clipboard that breaks everything on the Mac .

Hi folks.

In the continuing saga of broken round trip editing with the latest (17.1) version of ChemDraw, and Microsoft Office 2016/365 I thought I’d share with you, with permission, some communication I have had with Pierre Morieux (aka the ChemDraw Wizard, @ChemDrawWizard) from the ChemDraw team at PerkinElmer. It contains details about what exactly has broken in the last update.


Dear Martin,

I hope this e-mail finds you in a better shape than during our last e-mail exchange. You were quite quick to hammer on 17.1, and I thank you for that! https://chemistryandcomputers.wordpress.com/2018/04/05/chemdraw-17-1-update-released-micro-review-of-mac-version-round-trip-editing/

There is an explanation for what you observed: the reason is a change in the way Microsoft decides what to paste from the clipboard. The way SMILES was registered as textual data meant that MS Office preferred to paste it instead of the PDF image  from the document. We worked around this by removing the problematic registration from the SMILES type. The problem is that if there are multiple versions of ChemDraw installed on the system, the old registration will conflict with the newer cleaned up one. Users need to remove old versions entirely from their system and clean up there launch services database using the command line.

The following command line can be used to remove an old version: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

If more technical information is needed: https://www.cocoanetics.com/2012/09/fun-with-uti

If you think it may help your readers, could you convey the information?

Please let me know,

Pierre


I don’t know much about what else resetting the Launch Services database does on your system, so I would strongly advise you to back everything up properly before trying this fix. I haven’t been brave enough to delete the old versions of ChemDraw on my main systems yet, as I keep them to guard against future problems. And I certainly don’t know if the problem would recur if you tried to go back and use an older version in between 17.1 sessions, but I may go and do so on a separate external USB High Sierra boot disk that I have set up for testing. I’ll let you know how that pans out. – Martin

About martin

almost on holidays
This entry was posted in Chem, ChemDraw, mac, software and tagged , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s